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Introduction to Dreamweaver 3

Course Description: This class introduces the Macromedia Dreamweaver program for web
design and HTML editing for the experienced PC user. Topics covered include setting up your
first website, familiarization with the Dreamweaver workspace, and basic design.

Prerequisites: working knowledge of the PC operating system or completion of the Infroduc-
tion to the PC course. Familiarity with the Internet and HTML is helpful.

This document has been prepared for you by W&MF staff so that you can familiarize yourself with the
basics of Dreamweaver 3. This pamphlet is meant to serve as a future reference for you--not all infor-
mation mentioned in this document will be covered in today’s dass.

What is Dreamweaver?

Macromedia Dreamweaver 1s one of the top web design programs on the market, used by protession-
als and beginners alike. Dreamweaver is called 2 WYSIWYG (What You See Is What You Get) design
environment, which means that the program will take care of converting your ideas into HTML,
leaving you with time to do more important things.

l. Getting Started

Launch Dreamweaver 3 by going to: Start Menu::Programs::Networking::DreamWeaver. Click on the icon
to start the program.

Betore you work on individual pages, you need to set up your site using the site management features.
To set up a site in Dreamweaver, you first need to create a folder on your hard drive that will hold all of
your webpages. Minimize the Dreamweaver window and then right click on an empty area of the
desktop. Select New::Folder. Let’s name this folder nebsite for clarity’s sake.

Now we’ll go through the steps of defining a site. This means telling Dreamweaver where the website
folder can be found and providing some other information.
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1. Choose Site::New Site
The Site Definition dialog box appears. Make sure that the Local Info category is selected in the
left side of the dialog box.

2. In the Site Name text box, type a name for your site.

You can call your site whatever you like. After you name it here, the name appears as an option
on the drop-down list of the Site dialog box. You use this list to select the site you want to work
on when you open Dreamweaver.

3. Use the Browse button next to the Local Root Folder text box to locate the website folder
on the desktop.

4. If it isn’t already selected, click to place a check mark in the box next to Refresh Local
File List Automatically if you want Dreamweaver to automatically update the list of all the
new pages you add to your site.

5. Under Link Management Options, type the URL of your website in the HTTP Address
text box. (If you don’t have a website address yet, just leave the box blank.)

6. Click OK to close the Site Definition box.
A message will appear asking if you’d like to create a cache for the site. Dreamweaver offers this
option because it can work faster when there 1s a cache. Go ahead and say Yes.

11. Web Server Access

In order for people to see the website that you will create, you must have access to a web server. This
is a machine that stores the files you have created and then sends them to people when they request
them. You can gain access to a web server for free from providers such as geocities.com or tripod.com.

You enter information about the web server where your site will be published on the Web Server
Info page of the Site Definition dialog box (See Section 1). The Web Server Info page is accessible
tfrom the right side of the Site Definition Box.

Because we won’t be publishing anything today, choose None from the Server Access list on the
Web Server Info page.
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When you do publish your website, most likely you will be using a remote server, such as an
Internet Service Provider. Ask your Internet Service Provider for the following information:
FTP host name
Path or host directory
FTP login
FTP password
Then choose FIP from the Server Access drop-down list and follow these steps:

1. In the FTP Host text box type the hostname of your web server.
2. In the Host Directiry text box, type the directory on the remote site in which documents
visible to the public are stored (also known as the site rooi).

It should look something like public/html/ or www/public/docs/.

3. In the text box next to the Login and Password, type the login name and password re-
quired to gain access to your web server.

4. Put a check in the Use Passive FIP or Use Firewall options only if your service provider
or site administrator tells you to. (Don’t check any if you are in doubt.)

5. If you want to check any other settings, click OK to save your Web Server Info settings
and close the Site Definition dialog box.

I1l. The Dreamweaver Workspace

When you launch Dreamweaver, a blank page--called the norkspace--appears automatically, much like a
blank document appears in Microsoft Word. You can type text directly into the Workspace, and you
can apply basic formatting, such as bold and italics, simply by selecting Text::Style::Bold or
Text::Style::Italics. Webpages are built in the Workspace, which consists of a main window that
shows the HI'ML pafe you’re working on and a number of floating palettes and windows that provide
tools to design and develop your webpages. The Dreamweaver Workspace consists of four basic
components: the document window, floating palettes, menu bar and status bar.

The Document Window

The big, open area on the Workspace 1s the document window. It’s essentially a blank page, but what
you create there is automatically converted into HIML code. The document window displays text,
images and other elements in the same way thata web browser does. (Though things will look slightly
different depending on which version of Netscape or Internet Explorer is used to view the page--it’s
best to test your page on several versions to get the best design.)

The Floating Palettes

The tloating palettes in Dreamweaver provide easy access to many of the program’s features. You can
move the palettes around or close them if they get in your way. To get them back, choose Window
trom the pull-down menus and select the palettes you'd like to use.
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Here’s a list of some of the floating palettes that you will be using most frequently:

The Objects Palette: Contains buttons for creating HI'ML elements, such as tables, layers, and for
inserting images, plug-in files and other objects. There are six menus within the objects palette--use the
pull-down menu at the top of the palette to access the other features.

The Property Inspector: This palette displays the properties of a selected element (such as an image
or link) on the page. A property is a characteristic of HI'ML--such as the alignment of an image or the
size of a cell in a table.

The Launcher: A palette that allows for easy access to more advanced features of Dreamweaver,
such as HIML and CSS Styles, Behaviors and the HTML source window.

The Menu Bar

At the top of the screen, the Dreamweaver menu bar provides easy access to all the features that you
tind in the floating palettes, as wells as a few others that are available only from the menu.

The File Menu: Under the file menu, you find many familiar options, such as New, Open, and
Save. You also find the Revert option, similar to “Undo--"this feature allows you to return to the last-
saved version of your page if you don’t like the changes you've made.

The Edit Menu: The familiar Cut, Copy, and Paste reside on the edit menu. You can also find the
Preferences settings here. This feature allows you to set up the program so that it works best for you.
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The View Menu: This menu gives you access to some helpful design features, such as grids and rulers.
For more advanced users, this menu allows you to turn on or off the borders of your HI'ML tables,
trames and layers.

The Insert Menu: From this menu, you can insert elements such as a horizontal rule, a Java applet, a
Flash movie, a form, or a plug-in file.

The Modify Menu: Another place where you can view and change object properties, just like the
Property Inspector.

The Text Menu: You can easily format text with the Text menu by using simple options, such as Bold
or Italic, as well as more complex features, such as font styles and custom style sheets.

The Commands Menu: The features on this menu are useful when you want to automate a task, such
as making a certain size table. The Start and Play Recording features are similar to the Macro feature
in Microsoft Word.

The Site Menu: This menu provides access to the options you need to set up your site, a process
required before many of the other Dreamweaver features will work properly. (These features were
covered in the first sections.)

The Window Menu: The Window menu enables you to control the display of palettes and dialog
boxes. If you want to see a palette that isn’t visible in the workspace, simply select that palette tfrom the
menu. Items with check marks mean that these palettes are currently visible.

The Help Menu: Easy access to help options that can assist you in figuring out the many features of
Dreamweaver. You also find access to the Dreamweaver template and example files under Help.
Templates and examples provide visual samples of common HTML designs, such as tables and frames,
and provide design ideas and great shortcuts for creating more complex layouts.

The Status Bar

The Status Bar appears at the very bottom of the screen. On the right end of the Status Bar, you can
see shortcuts to all the features on the Launcher palette. On the left end, you find HI'ML tags that
indicate how your elements are formatted. This feature makes double-checking the kind of formatting
applied to any element on your page easy. To turn the display of the Status Bar on or off, choose
View::Status Bar.
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IV. Creating New Pages

Every web page begins with a single page--the home page--this 1s a good place to start.
Dreamweaver makes it easy: when the program opens, it automatically creates a new page. To
create another page, choose File::New.

Creating a new page to start a website may seem obvious, but consider this: you may want to
create a bunch of new pages before you get too far in your development, and you may even want
to start organizing the new pages in subdirectories before you have anything on them. This
process enables you to organize your pages before you start linking them together. After all, you
can’t set a link to a page that doesn’t exist yet. So if you plan to have five links on your front
page to other pages in your website, go ahead and create those other pages, even if you don’t put
anything on except a headline of what you will make the page into later.

V. Designing Your First Page

This section will give you all the basics, such as formatting text, adding images and setting links.
When you’re ready, click within the new document in the workspace and type anything you’d
like.
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Suppose you want to center a line of headline text and apply a heading tag to make it large and
bold. To create a headline, follow these steps:

1. Highlight the text that you want to format.
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2. Choose Text::Format::Heading 1.
Headline 1 1s the largest option, Heading 2 is the next largest, and your choices go all the way
down to Headline 6, the smallest headline size.

3. With the text still selected, choose Text::Alignment::Center.
The text will automatically center. Now you should have a headline at the top of your page.

Indenting Text
Type a little more text after your headline text. To indent that text, follow these steps:

1. Highlight the text that you want to indent.

2. Choose Text::Indent.
It you want to continue adding text and you don’t want it to be indented, choose
Text::Format::None to change back to plain text mode.

Adding Images

Adding an GIF or JPEG formatted image to your webpage is simple with Dreamweaver. There
are two important things that you need to do before inserting an image onto a page. First, save
your HTML page in your website’s folder on your hard drive. This step is important because
Dreamweaver can’t properly set the path to your image until it can identify the relative locations
of the HTML page and the image. Until you save the page, Dreamweaver doesn’t know what
tolder the page will be in.

For this same reason, you need to make sure that the image file is where you want to store it on your
website. Many designers create a file called Izages so they can keep all their image files in one place.
Ever see those broken picture icons when you try to look at a website? That’s often because the
picture was moved after the link was already set to a certain location. If for some reason you do end
up breaking a link, simply delete the broken image icon that appears in its place and insert the image
again by following the steps below:

1. Click the Image icon in the Objects palette.
The Image dialogue box opens.

2. Click the Select button.
A dialog box opens, displaying the files and folders in your hard drive.

3. Navigate to the folder that has the image you want to insert.
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4. Double-click to select the image you want.

The image automatically appears on your webpage.

It you have not already saved your page, a warning box pops up to tell you that Dreamweaver
cannot properly set the link to the image until you save the page. If you see this box, cancel the
step, save your page by choosing File::Save and then repeat the preceding steps.

5. Click the image on your webpage to display the image options in the Property Inspector.
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Use the Image Property inspector to specify the image attributes, such as alignment, horizontal
and vertical spacing, and alternative text.

Setting Links

A link 1s essentially an address (URL) that tells a viewer’s browser what page to go to when the
viewer selects the text or image with the link. If that page is within your website, you want to
create a relative /ink that includes the path that describeshow to get from the current page to the
linked page. A relative link should not include the domain name of the server. This is an ex-
ample of a relative link:

<A HREF=%“staff/vanessa.html”>Vanessa</A>

It you link to a page on a different website, you need to create an absolute link. An absolute link
includes the full Internet addressof the other site. This 1s an example of an absolute link:
<A HREF=“http://www.google.com”>The Best Search Engine</A>

It all that HREF code stuff looks strange, don’t sweat it, the next section will show you how to
set links without even knowing what the code means.

Linking Pages Within Your Website

Linking from one page in your website to another--an znternal ink--is simple. The most important thing
to remember is to save your pages in the folders that you want to keep them in before you start setting
links. If you set a link and then move the page that you linked to a new location, you break the link.
This 1s how you create an internal link:

1. In Dreamweaver, open the page to which you want to create a link.

2. Select the text or image that you want to act as a link.

3. Choose Window::Properties to open the Property Inspector, if it isn’t open already.

4. Click the folder icon to the right of the Link text box.
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5. From the Select File dialog box, click the page that you want your image or text to link
to, and then click the Select button.

The link i1s automatically set and the window closes. If you haven’t saved your page, a message

box appears, explaining that you can only create a relative link after you save the page. You
should always save the page you’re working on before you insert images.

Linking to Pages Outside Your Website

Linking to a page on another website--an external link--1s even easter than makin an internal link.
All you need 1s the URL of the page to which you want to link and you’re almost done.

To create an external link, follow these steps:

1. In Dreamweaver, open the page from which you want to link.

2. Select the text or image that you want to act as a link.

3. Choose Window::Properties to open the Property Inspector

4. In the Link text box, type the URL of the page that you want to link to:
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The link 1s automatically set.

Setting a Link to an E-mail Address

Another common link option goes to an e-mail address. E-mail links make it easy for visitors to
send you a message. Before you start, you need to know the e-mail address to which you want to
link. The only other thing you need to know is that e-mail links must begin with the code
mailto:

To create an e-mail link in Dreamweaver, follow these steps:

1. In Dreamweaver, open the page on which you want to create the link.
2. Select the image or text that you want to act as a link.

3. Choose Window::Properties to open the Property Inspector

4. In the Link text box, type mailto:, followed by the e-mail address.

The link is automatically set. When a visitor clicks an e-mail link, the browser automatically opens an e-

mail message window where the user can type a message and send it to you.
= - s - - .
5 B .

T 'r‘n,;-u-‘,, L5

Eowar [hre B [DatvatFom 8]t fcee [ [ B S| E &3
[T |mai|to:vmartin@cafe.berkeley.e: BF_1 ]-l'Hl 'l IEREE (] é"




Workstation and Microcomputer Facilities - Introduction to Dreamweaver 3 - Last Revised August 17,2000

V1. Putting Your Website Online (At Home)

Section I detailed how to set up a site and enter the address, login name and password for your
server. This section tells you how to put pages on your server and retrieve them using the built-
in FTP capabilities of Dreamweaver.

To transfer files between your hard drive and a remote server, follow these steps:

1. Choose Site::Open Site and select a site definition.
The Site dialog box appears.

2. Click the Connect button.

If you're not already connected to the Internet, the Connect button should start your dial-up
connection. Once you’re online, Dreamweaver will establish a connection with your host server.

After you establish the connection to your web server, the directories on your server appear in
the left pane of the Site dialog box. If the files on your local hard drive don’t appear in the right
pane of the dialog box, use the small arrow at the bottom-left corner of the dialog box to open the
right pane.

3. To upload a file drag the file or folder from the right pane to the left pane.
4. To download a file, drag files from the left pane to the right pane.
The files are automatically copied when you transter them. When the transfer is complete, you

can open the files on your hard drive or use a web browser to see the files you've uploaded to the
remote server.

VIl. Conclusions

By this time, we hope that you have a fairly good understanding of the commonly used features
of Dreamweaver 3. There are plenty of features that weren’t covered, and you can learn more

about these in our next class, Intermediate Dreammeaver 3. Please feel free to ask the teacher or
roamers if you have any questions regarding the course material.

Please fill out an evaluation telling us what you thought of the course before you leave, and thank
you for attending Inroduction to Dreamweaver 3.
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VIIl. Other Resources

Visit the Macromedia website [www.macromedia.com| to download a 30-day trial version of
Dreamweaver 3, as well as several other web development tools.

On the same website, www.macromedia.com/support, you can find Macromedia’s official help
center. The site 1s filled with tutorials, samples and other assets designed to keep developers up-to-date.

www.webmonkey.com features helpful tutorials, useful info, design tips and references, and also
dragnostic tools to test your browser and find out about plug-ins and other web development tools.

www.zdnet.com provides a large database of web design resources.

Finally, look ftor our Intermediate Dreammearer 3 course on the Walk-in class schedule to take your web
development skills to the next level.



