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Intermediate
MS EXCEL 97

for PC

Workstation & Microcomputer Facilities
Information Systems & Technology
University of California at Berkeley

This document has been prepared for you by W&MF staff so that you can further your understanding of
Microsoft Excel 97 for Windows NT.  This document is meant to serve as a future reference for you.  Not all the
information mentioned in this document will be covered in the Intermediate Excel class.  Before taking this
course, you should have completed the Introduction to MS Excel, and be familiar with the Windows NT
computing environment or have completed the Introduction to the PC class.

What you should know before taking this course:
•Using the Mouse
•Window Control
•File Management -- Open, New, Worksheet Name, Save and Save As....
•Data Entry
•Editing -- Cell Selection, Insert, Delete, Clear, Cut, Copy, Paste, Fills
•Basic Formatting -- Column Width, Row Height
•Formula Entry -- Writing a Formula, using the Function Wizard, Relative and Absolute

Referencing, Autofill
•Printing -- Worksheet

What you will learn in this intermediate course:

•Review -- Basic Controls, Cell Selection, Formula Entry
•Making a Chart -- Using the Chart Wizard
•Editing a Chart -- Moving, Resizing, Changing Chart Type, Adding and Deleting Axis

Labels, working with Legend
•Formatting a Chart -  Chart Type, Chart Area, Plot Area, Data Series, Axis, Legend, Data

Point
•Sorting
•More Worksheet Features --  Quick Insert and Delete,  Split Screen, Freeze Panel, Hide

and Unhide, Outlines

Items covered in Beginning Excel that are not necessary for this course:

• Basic Formatting -- Font, Point Size, Text Alignment, Border, Patterns
• Printing
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Before We Begin.....A little Review

• Data Entry
- You can enter data in a cell by selecting the cell and typing. To enter data quickly into
several adjacent cells, first select the rage of cells (highlighting). You can then make cell
entries, one after another, in successive cells. See Table 1 - Basic Controls below for a quick
reference guide on moving around in Excel 97.

Keys
Action General Scrolling When Highlighted
Move down one cell down arrow enter
Move up one cell up arrow shift+enter
Move right one cell right arrow / tab tab
Move left one cell left arrow / shift tab shift tab

Table 1 - Basic Controls

*Important reminder:  Do not use the arrow keys when you are entering data or when you have
cells highlighted. Using your arrow keys will result in selecting a new active cell.
- You can complete a cell entry or an edit you’ve made to an entry by clicking the enter box  
or by pressing ENTER. You can cancel an entry or edit by clicking the cancel box   or by
pressing ESC.

• Cell Selection
- Before we can edit any cell entry/entries, we must select the cells we want to edit. See Table 2
- Cell Selection for a quick reference guide on cell selection.

Action Keys
Selecting a single cell 1. Mouse / 2. Arrow keys /

3. Using Coordinate 
Selecting an entire row 1. Click on the row header of the row you want to select
Selecting an entire column 1. Click on the column header of the column you want to select
Selecting an entire worksheet 1. Click on the box where the column and row headers meet
Selecting multiple adjacent cells 1. Drag the mouse over the cells you want to select or,

2. Using the mouse or arrow keys, select the first cell (top most corner)
of the cells you want, then hold down the shift key and select the
last cell (bottom most opposite corner) of the cells you want.

Selecting multiple adjacent columns or
rows

1. Drag the mouse over the row/column header of the rows/ column
you want to select, or

2. Using the mouse or arrow keys select the first row / column of the
rows/ column you want, then hold down the shift key and select the
last row / column header of the rows / columns you want.

Selecting multiple non-adjacent cells 1. Using the mouse, select the first cell of the cells you want, then hold
down the control key and select the rest of the cells you want.

Selecting multiple non adjacent rows or
columns

1. Using the mouse select the first row / column of the rows/ column
you want, then hold down the control key and select the rest of the
rows / columns you want.

Table 2 - Cell Selection
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• Quick Edit Menu
To activate the Quick Edit Menu:
- Press the right hand mouse button.
To activate the commands in the Quick Edit Menu:
- Drag the mouse pointer to the command you want and release the
mouse button to activate.

What’s the difference between Clear and Delete?
- If a cell content is cleared, its value is zero and the cell remains. However when a cell is
deleted, the cell is completely removed causing adjacent cells to shift upward or to the right.
This causes two main problems.

  Aesthetics - Clearing a cell lets the cell remain while deleted cells will have to be replaced
by an already existing nearby cell. Thus, shifting your worksheet data around.

 Formulas - if you enter the formula =A1*B1 in a cell and then cleared cell B1, the result of
the formula will be zero (A1*0). But if B1 was deleted, the cell containing the formula
=A1*B1 is changed to =A1*#REF! and produces the #REF! error value to let you know
that you need to adjust your formula.

- This is a common error among Excel users who are just trying to clear the existing cell of
old data or formats so that they can enter a new set of data or formats. But by deleting the
existing cell, they no longer have the correct cell(s) or space to enter their new information.

• Width and Height
- To change the height or width of a cell:

Select the cell you want to format
Activate the Format menu and chose row then height or

column then width
- changing a cell width will automatically change the
width of the whole column and changing a cell height
will automatically change the row height.

Using auto fit to change the width of a column and height of a row.
AutoFit will automatically fit your cell to the exact size of the entry in you cell. However, if
a column is selected when you activate the AutoFit command, Excel will automatically size
each cell to the widest cell in that particular column or make the row height equal to the
tallest entry of the row if a row is selected.

Changing  Column Width and  Row Height without the using the Format menu
Put cursor on the line between the column or row heading you want to format.
The cursor should turn into a symbol with two arrows on it.

    Now drag the symbol to your desire height or width.  or
    Double click the mouse button to autofit the entire row or column.
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Worksheet Basics

• Creating a Series

- Several types of data repeat in logical sequence. Days of the week and months, for
example, repeat predictable patterns, These data types and their sequences are listed in the
following table. Excel can repeat several such sequences when you create a series.
You can create a series using the Fill Series menu or by dragging.

To create a series with the Fill command:
  In the first cell where you want to start the series, enter a starting value.
 Select the cells in the row or column in which you want to extend the series, starting

at the cell in which you entered the starting value of the series.
  From the Edit menu, chose Fill Series... .

- Chose the series type (linear,
exponential)

- Chose the linear increment, or
growth factor you want to use

- Chose when you want Excel to
stop extending the series.

- Hit OK when finish

To create a series by dragging:
  Select  a range of two cells and enter the first two values for the series. Leave the range
selected.
  Move cursor over to the bottom right corner of the selected range called the fill handle.

 Cursor should turn into black cross. 
 Drag the fill handle and release the mouse button at the end of the range into which
    you want to fill.
- Excel determines the incremental changes between the cells and adjusts the values of
the series by the same amount. Excel in not always accurate with its determination.
Step 3

 Step 4   - Result
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• Formula Entry

A formula is a simple way to evaluate a series of values. Each formula starts with an equals
sign “=“ followed by either a cell reference  (such as “A1”) or a value  (such as “1875”).
Usually a formula contains several series of values of cell references each separated by a
math operator. (see Table 3)

A typical formula might look like this = X2 * (D2 - B2)

** Remember to use parenthesis to show what operations should be done first.

Function Sign
Division /

Multiplication *
Subtracting -
Addition +
Power ^
Table 3 Math Operators

• Relative Referencing
- A relative reference tells Excel how to find another cell, starting form the cell containing
the formula. Reference such as C4 and F7 are relative references.
- When you copy formulas and functions, Excel automatically adjusts the cell references so
that it works correctly. Excel calls this method of adjusting the references relative
addressing, which means that as you copy the cell to another location, Excel adjusts the
references in a relative manner. Thus if you copy the formula “A1+B2” in cell E1 over to cell
F3, Excel adjusts the formula to “B3+C4” by “adding” a column and two rows to the
references in the current function.

• Absolute Referencing
- An absolute reference tells Excel how to find a cell based on the exact location of that cell in
the worksheet.
- When you have a reference that must stay fixed, you mark it as an absolute reference. An
absolute reference is a cell reference that Excel does not adjust when you copy or move the
cell.

To mark an absolute reference:
  Select the cell reference that you must mark as an absolute reference
 Mark an absolute references in your formula with a dollar sign ($) before the column letter

or the row number or both.
Ex. Your formula multiples cell A5 with cell C1 (=A5*C1) and you copy the formula to

another cell, both references will change. You can create an absolute reference to cell C1
by placing a dollar sign ($) before the parts of the reference that do not change. To
create an absolute reference to cell C1, for example, add dollar signs to the formula as
follows:

 =A5*$C$1
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How can I decide when to use Relative or Absolute References?

Use a relative reference (such as B5) if you want to refer to cells relative to the cell containing
the formula, even if you copy the formula. Use an absolute reference when you want to refer
to the same cell regardless of where the formula is located on the worksheet.

For Example:

- correct use of reference

- wrong use of reference

- If you want to know the monthly spending as a
percentage of the total spending. You would divide
January Spending by Total Spending. Thus, you would
write the formula “=Y2/$Y$14” or “Y2/Y14” for the
month of January.

- If you wrote “=Y2/$Y$14”, as you fill or copy the
formula to the cell AA3 the formula will automatically
change to “=Y3/$Y$14”. The relative reference “Y2”
,January Spending, will change to “Y3”, February
Spending, while your absolute reference “$Y$14”, Total
Spending”, stays the same.

- However, if you wrote the formula “Y2/Y14” for the
month of January, as you fill or copy the formula to the
cell AA3, the formula with the relative reference “Y2”
,January Spending, will change to “Y3”, February
Spending. But the relative reference “Y14” which referred
the Total Spending will change to “Y15”, which has a
value of Zero. This will lead to a wrong value.

You could type the formula into each cell. Thus having to avoid the error of relative
referencing.

• Functions
- A function is a special prewriting formula that takes a value or values, performs an
operation, and returns a value or values. Functions can be used alone or as building blocks
in other formulas. Using functions simplifies and shortens formulas in your worksheets,
especially those that perform lengthy or complex calculations. For example, instead of

typing the formula  “=A1+A2+A3+A4+A5”, you can use the Sum function  to build the
formula =SUM(A1:A4). The necessary data such as “A1:A4” are called arguments.

-
To  input any function:

  Write in any function with the correct arguments into your formula. or
  Click on the FUNCTION WIZARD Icon ,  or go to Function... under the Insert Menu
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• Using the Function Wizard
The Function Wizard will let you paste the correct function with the right inputs for the
necessary arguments.
• Step 1

- Step 1 of the function Wizard allows you
to pick the function that you want.

- Simply highlight the function that you
want and hit OK.

• Step 2
- Step 2 of the Function
Wizard will give you a
description at the bottom
detailing how many
arguments can be used and
what will be done to them.
Depending on which
argument that you are at,
Excel will give you a
description on what values are
needed in the specific
argument.

Number1, Number2,… refer to selected areas. With this option, groups of cells from
different parts of the sheet can be included into the function.

To input the range of data necessary for each argument:
  Type in the correct range or
  Select the range from your worksheet using your mouse. or
  If the require data input for the argument is a function, then hit the function wizard
icon next to the argument and repeat steps one and two to create the necessary input.

When you are done, hit the OK button or hit Cancel to change your function.
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• Copying values of formulas to Adjacent Cells

You can create a series using the Data menu or by dragging.

To create a series with the Fill command:
   Select the cell or cells you want to copy and the adjacent cells you want to fill.
 From the Edit menu, chose Fill and the direction you want to fill.

To create a series by dragging:
  Select the cell or cells you want to copy.
  Move cursor over to the bottom right corner of the selected range called the fill handle.
 Cursor should turn into black cross.
 Drag the fill handle and release the mouse button at the end of the range into which you

want to copy.
☞ You can always un-fill by dragging in the opposite direction.

Excel determines the incremental changes between the cells and adjusts the values of the
series by the same amount. If you don’t want Excel to adjust for the incremental
change, hold down the control key.

Making A Chart

Creating A Chart
Where do you want your Chart?

Before making a chart in excel, first you must decide where to put the graph. There are two
options. Make the chart on the current worksheet or make the chart on a new worksheet.

If you have lots of data and only making a chart out of a few data points, make a chart on a
new worksheet so that your worksheet does not become too cluttered. But if you want
your data next to the chart, you might opt for the chart on the current worksheet.

To create a chart on a New worksheet:
   Select the data you want to plot. Include cells containing labels for rows and columns that

you want used in the chart.
 Click the Chart Wizard tool or go under the Insert menu and select Chart.
 Go through all of the steps, then select the option As a new sheet.

To create a chart on the Current worksheet:
  Select the data you want to plot. Include cells containing labels for rows and columns that

you want used in the chart.
 Click the Chart Wizard tool or go under the Insert menu and select Chart.
 Go through all of the steps, then select the option As object in and select the desired sheet.
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• Step 1
* - Step 1 of the Chart Wizard is to select all of the cells

that will be used in the chart.
- Activate the Chart Wizard by clicking on the chart
button or selecting it from the Insert menu.

• Step 2

- Step 2 of the Chart Wizard allows you to select the type
of chart that you want.
- A select format for the chart type can be selected in the
menu named Chart sub-type.
- Select Next when you are done or Cancel if you have
made a mistake in the previous step.

What’s the difference between a Line chart and a (XY) Scatter chart?

Don’t let the picture fool you. Many users are unaware of the difference between a line and
scatter chart. Know the difference.

The line chart emphasizes time flow and the rate of change, rather than amount of change.
Which means that the line chart will plot each data point one tick mark apart regardless of
how far apart the x-data is. It only shows the difference between one point to the next.

The xy- scatter however will show the relationship or degree of relationship between the
numeric values in several chart data series. This means that Excel will calculates the scale
and tick-mark labels for the x-axis, just as it does for the y-axis. You will have the ability to
plot a line through xy-scatter.
An Example: If you were to plot pig numbers vs. how much they weigh. The numerical
value for the pig should not affect how the data is plotted since all pigs are equal. However,
if you were plotting Time vs. growth, both time and growth are dependent and must be
plotted according to scale.
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• Step 3

- Step 3 of the Chart Wizard allows you to select the
data range of your chart if you haven’t done so
already. Click on the small chart button to the right
of the entry field to select new data.
- The Series option allows you to manipulate the
data that the chart displays.
- Select Next when you are done or Back if you
have made a mistake in the previous step.

• Step 4

- Step 4 of the Chart Wizard allows you to
preview how your chart will look. You can also
add titles for the x-axis and y-axis as well as
change gridlines, the legend, and other features
of your chart.
- Select Next when you are done or Back if you
have made a mistake in the previous step.

  Data Series - select Rows if your data was enter in a rows (across) or select Columns
if your data was enter in a column form (up/down).

 Use First  Column(s)/Row(s) for Category (x) axis labels - use 1 if your first
column/row of your selected data are your label for the x axis or use 2 if your first 2
rows of your selected  data are your labels for the x axis. Select 0 if the first
column/row of your selected data is data that should be plotted.

 Use First  Column(s)/Row(s) for Legend Text. - use 1 if your first column/row of your
selected data are your label for a legend or use 2 if your first 2 rows of your selected
data are your labels for a legend. Select 0 if the first column/row of your selected
data is data that should be plotted.
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• You have now created a chart............

Don’t worry if you forgot to add a chart title or an axis label or even picked out the wrong
chart, we can always edit the chart after we are done.

Working With A Chart

• Selecting A Chart

- Select a chart by clicking one time on
the chart. Selected chart will have eight
tiny boxes around the edge called
handles.

• Resizing the Chart
If the chart you have created is too big or too small for your needs. You can resize any charts

by:
  Select the chart you would like to resize.
 Selected chart will have eight tiny boxes around the edge called handles.
 Select the appropriate handle.

 When the handle is placed over a handle, it turns into a double arrow. 
☞ Drag the chart to a new size.
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• Moving a Chart and its Contents
Moving a chart is similar to move a cell. Select the chart you want to move and drag it to the
new location.

You can move an open chart by dragging the chart by is border.

You can also move the Title, Legend, Axis Labels and even the plot it self from the opened
chart.
  Select the Object you are trying to move.
 Selected Object within the chart should have boxes around it.
 Move the object by dragging the object by its border.

Editing a Chart

 The Chart menu has the option Chart options
that allows you to modify the chart after you
had finished. Lets say you wanted to add a title
you forgot when you were making the chart.
Click on the chart to activate the chart functions
(the chart menu only appears when the charts
are selected). Click on the Titles tab to type in
your title. The same goes for the legends,

Another option is to use the chart bar that
appears when you select your chart. There are
options such as changing the type of chart to
modifying the way the data is presented.

• New Series or Data
To add a new series or Data to a chart

 Select the Chart you want to add the new data or series to.
 Under the Chart menu, select Add data...
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-  Select the new data that you want to add.
-  Depending on whether it was a row or not,
Excel will add the data to your chart
accordingly.

• Delete
To Delete  Legend, Chart Title, Axis Labels or any Series
   Select the object you want to delete (remember selected object will have handles on them)
  Hit the delete key or go to the Edit menu and select Clear All. and Clear Series for

deleting series.

• Format

With the Format menu, you can customize you chart by changing the chart type, the font of
the chart text, the horizontal and vertical alignment and rotate text to a vertical orientation.
You can also change the pattern and color of the chart and the color, and style of you chart
text.

Remember that you have to have you chart selected before you can select the items of the
chart and format it.

 The first line of the Format menu changes with whatever item you have selected.

✔ Chart Type
You can change the type of chart by clicking on the chart selection button.  on the chart
bar or  Open the chart you want to change and select Chart Type.. under the Chart menu.

Using the Chart Type menu will allow you to have more choices such as Style of chart, and
Series Order.
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✔ Chart Area
You can change the background color to the chart or the text on the chart by double-clicking
the chart area. The format window will appear and allow you to make the changes in the
Patterns tab.

✔ Plot Area
The default plot border and area for Excel 5.0 is gray. You can change that by double-
clicking on the plot area to bring up a format window and changing the color of the area
and border to your desire color.

✔ Data Series
- By selecting and formatting the data
series you can rename your series, change
the pattern (color and markers)of your
series, and add error bars or data labels to
your series.
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✔ Axis
By double-clicking the Axis you want to change, you can change the scale of the plot, the
tick marks of the axis, the orientation and font of the labels.

✔ Legend

You can change the font, placement and pattern of the
Legend.

More Worksheet Features

• Sorting

Excel allows you to sort the data that you have by Acceding or Descending order. Excel
will sort alphabetically or by numbers, unless its in a series format that excel recognizes
such as Dates or Months.

To sort the data that you have:
  Select the data and all the related data that you want sorted. (This is very important,

don’t just select the data that you are going to sort or don’t select data that is unrelated
to the data being sorted.)

 From the Data menu, select Sort... .
 From the Sort Menu, chose the data column or row that you want to sort and its order.

If you have column or row headers, it will ask you to sort by the header name.
(Remember that you are not sorting independently here. In the example, you are telling

Excel to sort the last name first and them from the last name sort the first name.)
Common mistakes in sorting

There are two common mistakes in sorting. Many users forget or don’t select all the related
data. In the example, even though you are trying to sort by name, you must select their
phone number and addresses. Otherwise Excel will not sort the un-selected objects. In
Excel 5.0, Excel will sometimes it give you a warning that there is data adjacent to the
selected data and do you want Excel to select it before you sort.

The second mistake many users make is that they don’t use the dependent sorting. Selecting
the data and sorting it by their last name and then re-selecting the data and sorting it by
first name will give you a list alphabeticalize by first names. This is different than the
dependent sorting which will give you a list alphabeticalized by it last and first name.
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Right Way Wrong Way

Result: Result:

• Quick Fill Menu

To activate the Quick Fill Menu, hold down the control key when using auto fill.

• Quick Insert and Delete

To quickly insert new cell(s), column(s) and row(s):
  Select the cell(s) or column(s) or row(s) you are tying shift to open space for the new row

or column or cell.
  Position the mouse pointer over the fill handle.
 Press Shift and drag the fill handle   down for row or toward the  right for columns

or either direction for cells and select the number of rows or columns or cells you want
to insert.

 Release the mouse button
To quickly delete cell(s), column(s) and row(s):

  Select the cell(s) or column(s) or row(s) that you are tying to delete
  Position the mouse pointer over the fill handle.
 Press Shift and drag the fill handle   up for row or toward the  left for columns or

either direction (up or left) for cells and select the rows or columns or cells you want to
delete. (Dragging past the selection will result in inserting new cells)

 Release the mouse button.
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• Split Screen
-  Sometime when your worksheet becomes really enormous, that are data you want to see
that can’t be fit into one screen. For example, if you wanted to enter on column AZ and you
row headers are on column A. Excel will allow you to split you screen to allow you to  view
more than one part of your worksheet at the same time.

- You can spit the window in 4 by selecting
Split under the Window menu.

The windows of Excel can display 2 (or 4)
separate parts of the worksheet
simultaneously.

Simply click and hold down the mouse
button on the small black area just left of the
left scroll arrow or just above the up scroll
arrow.

Your cursor should change from  to  (if
you are clicking above the up scroll arrow)
or  (if you are clicking left of the left
scroll arrow).  This means that you can now
place one the window dividers anywhere
along the length of the axis.  Each axis can
have but one divider, but both the X and the
Y axis can have it’s own axis, for a total of 4
different “panes”.

• Freeze Panel

If there is a certain part of the worksheet that you always want on your screen (like your row
headers)
After you have split the screen and isolated the column(s) or row(s) you like to freeze, select
Freeze Panel from the Window menu. Excel will freeze the upper right panel.
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• Hide and Unhide
Excel allows you to hide columns and rows. You might want to hide data that is only use for
calculation but is not necessary for the report or data that is confidential to some parties.
Hidden column(s) are not printed.

To hide of unhide a column(s) or row(s):
  Select or column(s) or row(s) that you are tying to hide
  Under the Format menu, select Column/Row Hide or Unhide.

• Outlines
Outlines allows you to hide and unhide columns and rows quickly. Outlining makes it easy
to move through many rows of data, rearrange parts of a worksheet, and create charts form
similar levels of data from different parts of a worksheet.


