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Intermediate MS Excel 5.0 for Macintosh

Course Description:  This class is a continuation of the Excel 1 Introductory class. Features discussed include worksheet
space management, working with formulas, creating charts and graphs from data input, and data analysis.

Prerequisites:
Before taking this course, you should have completed the Introduction to MS Excel class and be familiar with the
Macintosh computing environment or have completed the Introduction to the Macintosh class.

This document has been prepared for you by W&MF staff so that you can further your understanding of Microsoft Excel
5.0 for the Macintosh.  This document is meant to serve as a future reference for you.  Not all the information mentioned in
this document will necessarily be covered in the Intermediate Excel class

GETTING STARTED

You should be familiar with most of the basics of Microsoft Excel, including selecting cells,
moving about the worksheet, and basic formatting.  Other features like cut and paste, entering in
formulas, and the function wizard are covered in earlier classes.  If you have any questions about these
topics, please feel free to ask the instructor or roamer, but please remember that we will quickly move
into some of the more intermediate features.

This class will show you how to work with and interpret larger amounts of data.  We will show
how to format the looks of the spreadsheet to display it all, and cover references in formulas, so the data
will be handled correctly.  Later, we will create a chart to graphically represent the data.
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WIDTH AND HEIGHT FORMATTING

Sometimes the default width of a cell is not the right size for your data.  It may cut off extra
decimal places, or chop off the end of a column heading.  If a cell contains a large number that will not
fit inside, Excel will display ##### instead.  To avoid any of these problems, simply change the height
and width of the cell.

To change the height or width of a cell:
• Select the cell you want to format
• Activate the Format menu and chose row height or column width

Changing a cell width will automatically change the width of the
whole column and changing a cell height will automatically change the
height of the entire row.

Using auto fit to change the width of a column and height of a row.
There is an AutoFit selection under the Format Row option. AutoFit will automatically fit

your cell to the exact size of the entry in your cell. However, if a column is selected when you activate
the AutoFit command, Excel will automatically size each cell to the widest cell in that particular
column. If a row is selected, it will make the row height equal to the tallest entry in that row.

Changing Column Width and Row Height without using the Format menu
• Put the mouse cursor on the line between the column or row you want to format.  (i.e. in order to

format column D you must put the cursor on the line between column D and E)
 

• The cursor will turn into a symbol with two arrows

• Now drag the symbol to your desired height or width. 
 
You can also double click the mouse button to autofit the entire row or column.
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WORKING WITH THE SCREEN

Split Screen
Sometimes when your worksheet contains a large amount of data, which can not fit into one

screen, you can use Excel’s Split Screen feature to see separate parts of your data simultaneously. For
example, if you want to edit column Z and your row headers are on column A, Excel will allow you to
split your screen so you can view separate part of your worksheet at one time.

You can split the window in 4 by selecting Split
under the Window menu.

The windows of Excel can display 2 (or 4)
separate parts of the worksheet simultaneously.
Simply click and hold down the mouse button on
the small black area just left of the left scroll
arrow or just above the up scroll arrow.

Your cursor should change from  to 
(if you are clicking above the up scroll arrow) or

 (if you are clicking left of the left scroll
arrow).  This means that you can now place the
window divider anywhere along the length of the
axis.  Each axis can have only one divider, but
both the X and the Y axis can have one, for a total
of 4 different “panes”.

To unsplit windows, move the mouse
cursor on the divider line and double click on it.
You can also go to the Window menu and select
Remove Split.

Freeze Panes
Freeze Panes is used if there is a certain part of the worksheet still while you scroll around. For

example, if you want a row header to remain at the top, you can freeze that particular  row with the
header in it.

Use the Split Screen feature and divide up the screen where you want the data to remain still.
Then go to the Window menu and select Freeze Panes. You can then scroll within one of the panes
while the other pane remains still.

To remove the Freeze Pane feature, go back to the Window menu and select Remove Panes.
Then go back to the Window menu and select Remove Split.

Hide and Unhide
Excel allows you to hide columns and rows. You might want to hide data that is only used for

calculation but is not necessary for the report or data that is confidential to some parties. Hidden
column(s) are not printed.

To hide column(s) or row(s):
• Select column(s) or row(s) that you are tying to hide
• Under the Format menu, select Column/Row Hide.

To unhide column(s) or row(s):
• Select the surrounding columns or rows of the one that you are tying to unhide
• Under the Format menu, select Column/Row Unhide.
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View
Because your worksheet may contain a large volume of data, you can choose different view

modes depending on your task. Go to the View menu and select Zoom. Then choose a magnification
size suitable to your needs.
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FORMULAS AND VALUES

A formula is a simple way to evaluate a series of values. Each formula starts with an equals sign
“=” and can contain both cell reference s (such as “A1”) or values  (such as “1875”) separated by math
operators. (such as “+” or “-”).  They may be also combined together in an Excel function (such as
“SUM” or “AVERAGE”).

All of these expressions are formulas. You
can enter in a formula by typing it into the cell.

=A1
=A1+A2+100
=(A1*A2)/B4
=AVERAGE(A1:A99)

For instance, I may have a sheet like the one below:

In this case, the formula in cell Y14 is:
=SUM(Y2:Y13)
representing the sum of the values from Y2 through Y13.
If I change any of those values, the cell in Y14 recalculates
and displays the updated value.

If you want to lookup the name of a particular
Excel function, click on the  to bring up the
Function Wizard.
From there you can choose the name of the
function that you want.

Common Problems with Formulas and Values
Many times users experience some of the following error message. Refer to the following table

to understand the error message.
Error Value Means that a formula:
# DIV/0 is trying to divide by zero (or the cell the formula

is referencing to has no value)
# N/Å refers to a value that is not available.
# NAME? uses a name that Excel doesn’t recognize.
# NULL! specifies an invalid intersection of two areas.
#REF! refers to a cell that is not valid.
#VALUE! uses an incorrect argument or operand.
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##### result of a formula that is too long to fit in a cell.
Readjust the width of the column to display result.
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REFERENCES

If you need to copy a formula from one cell to another, you need to be aware of references.  There are
three types of references.

Relative Referencing
A relative reference tells Excel how to find another cell, starting from the cell containing the

formula. References such as A1 and Y2 are relative references.
When you copy formulas and functions, Excel automatically adjusts relative references so that

the formula works correctly. If you create the formula A1+B1 in cell C1 and then copy that formula to
cell D2, one cell to the right and one cell down, the formula in cell D2 will be B2+C2.  Each of the
references in the formula have been moved one cell to the right and one cell down as well.

Absolute Referencing
An absolute reference tells Excel how to find a cell based on the exact location of that cell in the

worksheet.  These references have dollar signs in their names.
For example, if I create the formula $A$1+$B$1 in cell C1 and then copy that formula to cell

D2, the formula in cell D2 will still be $A$1+$B$1  You can say that the dollar signs force the row
number and column letter to freeze in place, and not change.

Mixed Referencing
As the name suggests, this is a mixture of the two.  You can refer to cells A$3 or $B4  This

means that, if you copy a formula with mixed references, this will only update the part of the reference
without the dollar sign.  If I copy the formula A$3 one cell down, and one cell to the right, the new
formula will be B$3  The $3 did not change, but the A did.

How can I decide when to use Relative or Absolute References?
Use a relative reference (such as B5) if you want to refer to cells relative to the cell containing

the formula, even if you copy the formula. Use an absolute reference (such as $B$5) when you want to
refer to the same cell regardless of where the formula is located on the worksheet.

In this example, I want to divide the amount of
money spent per month by the total amount in
Y14.

I put the first formula as =Y2/$Y$14
If I copy the formula down through all the months,
the Y2 will become Y3, Y4, etc. through all the
months, but the $Y$14 will stay the same, because
the total will always be in the same place.

So, each cell is the result of dividing the monthly
spending by the total spending.
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CREATING CHARTS

Where do you want your Chart?
Before making a chart in Excel you must decide where you want to put the chart. There are two

options; you can make the chart on the current worksheet or make the chart on a new worksheet.
If you have a lot of data and you are only making a chart out of a few data points, you may want

to make a chart on a new worksheet so that your worksheet does not become too cluttered. But if you
want your data next to the chart, you may opt to make the chart on the current worksheet.

To create a chart on a New worksheet:
• Select the data you want to plot. Include cells containing labels for rows and columns that you want

used in the chart.
• Go under the Insert menu and select Chart and On New Sheet.
• Be ready for Step one.

To create a chart on the Current worksheet:
• Select the data you want to plot. Include cells containing labels for rows and columns that you want

used in the chart.
• Click the Chart Wizard tool or go under the Insert menu and select Chart,  and  On This Sheet.
• Position the pointer where you want one corner of the chart to be.
• Drag the cross-hair to create an appropriate outline for the chart.
• Release the mouse button and be ready for Step one.

Step 1
Step 1 of the Chart Wizard tells you to
confirm that the cells you wanted are in the
range displayed.
If you did happen to select the wrong cells, go
ahead and move the Chart Wizard dialog box
and select the correct cell(s) or type in the
correct range.
Select Next when you are done

Step 2

Step 2 of the Chart Wizard allows you to
select the type of chart that you want.

Select Next when you are done or Back if
you have made a mistake in the previous
step.



University of California at Berkeley - Information Systems & Technology: WORKSTATION AND MICROCOMPUTER FACILITIES DIVSIION

Intermediate MS Excel 5.0 for Mac Page 9 of 14 Last Revised October 14, 1998

CREATING CHARTS (continued)

What’s the difference between a Line chart and a (XY) Scatter chart?
Don’t let the picture fool you. Many users are unaware of the difference between a line and

scatter chart. The line chart emphasizes time flow and the rate of change, rather than amount of change.
Which means that the line chart will plot each data point one tick mark apart regardless of how far apart
the x-data is. It only shows the difference between one point to the next.

The xy-scatter graph however will show the relationship or degree of relationship between the
numeric values in several chart data series. This means that Excel will calculate the scale and tick-mark
labels for the x-axis, just as it does for the y-axis. You will have the ability to plot a line through xy-
scatter.

An Example: If you were to plot race horse numbers vs. their weight, the numerical value for the
horse should not affect how the data is plotted since the horses’ numbers are arbitrary (line chart).
However, if you were plotting time vs. growth, both time and growth are dependent and must be plotted
according to scale (scatter chart).

Step 3

Step 3 of the Chart Wizard allows you
to select the specific format of the chart.

Select Next when you are done or Back
if you have made a mistake in the
previous step(s).

Step 4

Step 4 of the Chart Wizard allows you to
preview of how your chart will look. To
the right of the preview, there will be a
list of three options that can change how
your data is displayed.

• Data Series - select Rows if your data was entered in rows (across) or select Columns if your
data was enter in column form (up/down).

• Use First  Column(s)/Row(s) for Category (x) axis labels - use 1 if your first column/row of
your selected data is your label for the x-axis or use 2 if your first 2 rows of your selected data
are your labels for the x-axis. Select 0 if the first column/row of your selected data is data that
should be plotted.

• Use First  Column(s)/Row(s) for Legend Text. - use 1 if your first column/row of your selected
data is your label for a legend or use 2 if your first 2 rows of your selected  data are your labels for a
legend. Select 0 if the first column/row of your selected data is data that should be plotted.
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Select Next when you are done or Back if you have made a mistake in a previous step.
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CREATING CHARTS (continued)

Step 5

Step 5 of the Chart Wizard allows you the
option of adding a legend, chart title and
axis labels
Hit Finish when you are done or Back if
you have made a mistake in the previous
step.

You have now created a Chart...
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WORKING WITH CHARTS

Selecting A Chart

Select a chart by clicking one time on the
chart. A selected chart will have eight tiny
boxes around the edge called handles.

Opening a Chart

Double clicking on the chart will open it. An opened
chart will have the same eight boxes, but with a
thicker highlighted border.

Moving a Chart and its Contents
Moving a chart is similar to move a cell. Select the chart you want to move and drag it to the new
location.

NOTE:  You can move an opened chart by dragging the border of the chart. You can also move the
Title, Legend, Axis Labels and the plotted data from the opened chart.

• Select the object you are trying to move.
• The selected object within the chart should have boxes around it.
• Move the object by dragging the object by its border.
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WORKING WITH CHARTS (continued)

Resizing the Chart

If the chart you have created is too big or too small you can resize the chart by:
• Selecting the chart you would like to resize.
• The selected chart will have eight tiny boxes around the edge called handles.
• Select the appropriate handle.

• When the cursor is placed over a handle, it turns into a double arrow. 
• Drag the chart to a new size.
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EDITING AND FORMATTING CHARTS

How do I name my series?
• Select the series that you want to name
• Activate the Format menu and select Selected Data Series...
• In the Selected Data Series menu, select Name and Values
• Put series name into the Name box

Insert

The Insert menu allows you to insert or remove Titles (chart title, axis
labels, etc) , Data Labels, Legend, Axes, and Gridlines.

To insert a Legend
• Select the chart and click on the add legend button or
• Open the chart you want and select Legend under  the Insert menu.

To insert a Chart Title or Axis Labels
• Open the chart you want  and select Titles... under  the Insert menu

To Delete Legend, Chart Title or Axis Labels
• Select the object you want to delete
• Hit the delete key or go to the Edit menu and select Clear All

To add a new series or Data to a chart
• Select and Copy the Data from the worksheet you want to add..
• Open the Chart you want to add the new data or series to.
• Under the Edit menu, select Paste Special...
 
 
 

• Choose if you want to add the new data as a New
Series or New Points

• Choose if your data is in Rows or Columns or if the
Series name or Axes Label are included.

or

• Choose New Data... form the Insert menu.
• Type or select the Data on the worksheet you want to add.
• If there is not enough information, the Paste Special Menu will automatically come on.
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EDITING AND FORMATTING CHARTS (continued)

With the Format menu, you can customize your chart by changing the chart type, the font of
the chart text, and the alignment and rotation of text. You can also change the pattern and color of the
chart and the color and style of your chart text. The first line of the Format menu changes with
whatever item you have selected.

NOTE: Remember that you have to have your chart opened before you can format chart items.

Format Chart Type
You can change the type of chart by clicking on the chart selection button.   or  by opening the
chart you want to change and selecting Chart Type.. under  the Format menu.

Using the Chart Type menu will give you more choices, such as; Style of chart, and Series Order.

Format Chart Area
You can change the background color of the chart or of the text on the chart.

Chart Area Selected
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EDITING AND FORMATTING CHARTS (continued)

Format Plot Area
The default plot border and area for Excel 5.0 is gray. You can change that by selecting the plot area
and changing the color of the area and border to your desired color.

Plot Area Selected

Format Data Series

By selecting and formatting the data series
you can rename your series, change the
pattern (color and markers) of your series,
and add error bars or data labels to your
series.

Format Axis
By selecting the Axis you want to change, you can change the scale of the plot, the tick marks of the
axis, the orientation, and font of the labels.
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EDITING AND FORMATTING CHARTS (continued)

Format Legend

You can change the font, placement, and pattern
of the Legend.

Format Data Point

To select a certain data point, select the series that
contains the data point and then click on the data
point you want to format.

You can add labels or change the pattern of the
selected data point.

ANALYZING DATA INPUT
Once you have created your chart, you can analyze the plotted data in two major ways. First, you

can find the Trendline of your data. Double click on the chart to open it. Then click once on the data set
you want to analyze. Go to the Insert menu and select Trendline. When the window pops up, choose
the appropriate trendline type. Click on the Option tab to add more information regarding your
trendline.

For more powerful data analysis, go to the Tools menu and select Add-ins. Then click on the
checkbox beside Analysis ToolPak and then OK. Once Excel loads these extra tools into memory, you
can begin to use it by going back to the Tools menu and selecting Data Analysis. Choose the
appropriate anaylsis tool for your data.

CONCLUSION

By this time we hope that you have a fairly good idea of some of the commonly used features of
Excel.  Even though there were plenty of features that were not covered, we hope that you will find all
of the information presented useful.  If you have any questions, please ask the Instructor or Roamer.
Also try to experiment with the topics covered, and see what you can create as well.

Remember to fill out an evaluation before you leave, and thank you for attending Intermediate Excel.


